Agregar a favoritos      Ayuda      Português      Ingles     
 Página anterior Volver al principio del trabajoPágina siguiente 

Método de la bisección para encontrar raíces de funciones en Microsoft Excel (página 2)

Enviado por jaimemontoya



Partes: 1, 2

Programa para encontrar raíces utilizando el método de la bisección en Microsoft Excel

A manera de recordatorio, para que aparezcan solamente 6 cifras significativas, en Excel esto se hace en el menú Formato, Celdas…, Número, Categoría Número, Posiciones decimales 6. Para poner el signo porcentual: menú Formato, Celdas…, Número, Categoría Porcentaje.

EJEMPLO 1

Encontrar la raíz de f(x) = x^10 – 1 utilizando el Método de la Bisección con a = 0; b = 1.3; Tol = 0.01

Gráfico de la Función

 

La raíz aproximada de la función es 1.000391 con un error de 0.01.

Como se puede apreciar en la gráfica, la raíz exacta de la función es de 1, pero con 8 iteraciones se llegó a 1.000391. Si se continuara con más iteraciones, se podría llegar a un valor aun más cercano al 1 exacto, pero el error tendría en ese caso que ser menor que 0.01, que es el 1%.

EJEMPLO 2

Resolver utilizando el método de la Bisección.

Gráfico de la Función

La raíz aproximada de la función es 1.054688 con un error de 0.001.

EJEMPLO 3

Resolver utilizando el método de Bisección.

Gráfico de la Función

La raíz aproximada de la función es 0.361328 con un error de 0.001.

FÓRMULAS PARA PROGRAMAR EL MÉTODO DE LA BISECCIÓN EN MICROSOFT EXCEL

En la tabla que se presentará a continuación, no aparecen las fórmulas para cada una de las celdas porque serían demasiadas fórmulas. Basta con presentar algunas y todas las demás se deducen fácilmente. Además, al estar trabajando en Excel, bastará con copiar y luego pegar las fórmulas o celdas de una de las filas superiores porque las celdas de todas las demás filas serán las mismas, y Excel automáticamente irá cambiando correctamente todos los valores de forma apropiada. La tabla de fórmulas utilizada es la siguiente:

Celda

Fórmula

B15

= 1

D15

= 2

F15

= 0.001

A18

= 1

B18

= B15

C18

= D15

D18

= PROMEDIO (B18:C18) ó PROMEDIO(B18,C18)

E18

= 2.718281828^(-B18)+4*(B18)^(3)-5

F18

= 2.718281828^(-C18)+4*(C18)^(3)-5

G18

= 2.71828182^(-D18)+4*(D18)^(3)-5

A19

= A18+1

B19

= SI(B18*G18>0,D18,B18)

C19

= SI(B19=D18,C18,D18)

D19

= PROMEDIO(B19,C19)

E19

= 2.718281828^(-B19)+4*(B19)^(3)-5

F19

= 2.718281828^(-C19)+4*(C19)^(3)-5

G19

= 2.718281828^(-D19)+4*(D19)^(3)-5

H19

= ABS(D19-D18)

I19

= H19/D19

J19

= SI(I19<=F$3,D19,"")

J24

SI(I19<=F$3,D24,"")

 

 

 

 

Autor:

Jaime Oswaldo Montoya Guzmán

Estudiante de Ingeniería en Sistemas Informáticos.

Universidad Católica de Occidente (UNICO)

El Salvador

Santa Ana, 4 de febrero de 2007

 


Partes: 1, 2


 Página anterior Volver al principio del trabajoPágina siguiente 

Comentarios


Trabajos relacionados

Ver mas trabajos de Software

 

Nota al lector: es posible que esta página no contenga todos los componentes del trabajo original (pies de página, avanzadas formulas matemáticas, esquemas o tablas complejas, etc.). Recuerde que para ver el trabajo en su versión original completa, puede descargarlo desde el menú superior.


Todos los documentos disponibles en este sitio expresan los puntos de vista de sus respectivos autores y no de Monografias.com. El objetivo de Monografias.com es poner el conocimiento a disposición de toda su comunidad. Queda bajo la responsabilidad de cada lector el eventual uso que se le de a esta información. Asimismo, es obligatoria la cita del autor del contenido y de Monografias.com como fuentes de información.