Guia De Algoritmos Resueltos

603 palabras 3 páginas
GUIA DE ESTUDIO ALGORITMOS

1. Construya un algoritmo que permita ingresar el año de nacimiento de una persona y a partir de dicho año de nacimiento determine si la persona es o no mayor de edad. Recuerde que una persona es mayor de edad cuando cumple los 18 años.

Inicio Escribir “ Ingrese año de nacimiento :” Leer añoNacimiento Edad = 2009 – anoNacimiento Si ( edad >= 18 ) entonces Escribir “ La persona es mayor de edad” Sino Escribir “La persona es menor de edad” Fin_si Fin

Comentarios en relación a la solución: • • • Lo primero que debemos hacer es leer el año de nacimiento de la persona Determinar la edad de la persona se logra restando al año actual, el año de nacimiento. Finalmente preguntamos si la edad de la persona es
…ver más…

La promoción consiste en realizar un descuento a un cliente según el monto total de su compra. Los criterios para realizar el descuento son los siguientes: • • • Por compras inferiores a 10.000 el descuento es del 5%. Por compras entre 10.000 y 50.000 el descuento es del 20% Por compras sobre 50.000 el descuento es del 30%.

Construya el algoritmo que permita determinar cuánto es lo que finalmente debe pagar un cliente por sus compras dieciocheras.

Inicio Escribir “ Ingrese monto de la compra :” Leer montoCompra Si ( montoCompra < 10.000) entonces descuento = montoCompra * 0,05 sino Si ( montoCompra < 50.000 ) entonces descuento = montoCompra * 0,2 sino descuento = montoCompra * 0,3 Fin_si Fin_si valorPagar= montoCompra – descuento escribir “ monto a pagar : ”,montoPagar Fin

Comentarios en relación a la solución: • • • Lo primero que debemos hacer es leer el monto de la compra Si el monto de la compra es menor a 10.000 entonces calculamos el descuento del 5%. Si no se cumple la condición de ser menor a 10.000 y si se cumple que es menor a igual a 50.000 quiere decir que esta en el rango de 10.000 a 50.000 y le calculamos un descuento del 20% Si no se cumple ninguna de las condiciones anteriores quiere decir entonces que la compra supera los 50.000 por lo que calculamos un descuento del 30% Independiente del monto de la compra el descuento siempre se almaceno en descuento Finalmente se calcula el monto que

Documentos relacionados

  • Metodologia Para Resolver Algoritmos.
    1534 palabras | 7 páginas
  • Guia De Tic´S Segundo Semestre 2/2
    785 palabras | 4 páginas
  • Metodologia Para Resolver Algoritmos.
    1540 palabras | 7 páginas
  • Factores que influyen en la eleccion de canales
    1470 palabras | 6 páginas
  • Formas de comunicacion
    1226 palabras | 5 páginas
  • Counter definicion
    3752 palabras | 15 páginas
  • Archivo fisico
    2068 palabras | 9 páginas
  • A.P.O : Alternativas , Posibilidades y Opciones
    3564 palabras | 15 páginas
  • Intervención tanatologica en pacientes de vih/sida
    7507 palabras | 31 páginas
  • Lenguaje Algebraico
    1610 palabras | 7 páginas