Algoritmo

1467 palavras 6 páginas
Curso: Sistemas de informação
Matéria: Algoritmo

1. Leia um número e exiba seu sucessor.
Algoritmo “sucessor”
Var Numero1, : inteiro
Inicio
Escreva (“digite um número”)
Leia (numero1)
Numero1 , Numero1 + 1
Escreva ( “ Resultado”, Numero1)
Fimalgoritmo
2. Calcular a quantidade dinheiro gasta por um fumante. Dados: o número de anos que ele fuma, o nº de cigarros fumados por dia e o preço de uma carteira.
Algoritmo “cigarro”
Cigarros_carteira 20
Dias_ano 365
Var anos, cigarros_dia: inteiro
Preco, total: real
Inicio
Escreva (“A quantos anos você fuma”)
Leia( anos)
Escreva(“Quantos cigarros você fuma por dia”)
Leia (cigarros_dia)
Escreva(“preço da carteira”)
Leia(preco)
Total (cigarros_dias * dias_anos * preco
…exibir mais conteúdo…

Dado um número inteiro de segundos, mostrar a quantas horas, minutos e segundos ele corresponde.

Algoritmo “ tempo”

var segundos, horas, minutos:real

inicio escreva (“ informe quantidade de segundos”) leia(segundos) minutos segundos/60 horas minutos/60 escreva(“ segundos” , segundos) escreva(“ minutos”, minutos) escreva(“ horas”, horas) fimalgoritmo 10. Construa um algoritmo que, tendo como dados de entrada dois pontos quaisquer no plano, P(x1,y1) e P(x2,y2), escreva a distância entre eles. A fórmula que efetua tal cálculo é: algoritmo “ raiz” var x1, x2, y1, y2, resultado: real inicio escreva(“ valor para x1”) leia(x1) escreva (“valor para x2”) leia (x2) escreva(“valor para y1) leia (y1) escreva(“valor para y2) leia(y2) resultado ((x2-x1)^2+(y2-y1)^2)^0.5 escreva(“resultado é”, resultado) fimalgoritmo 11. Escreva um algoritmo que leia três números inteiros e positivos (A, B, C) e calcule a seguinte expressão:

onde R=(A+B) S=(B+C)

Algoritmo “expressao” var numero1, numero2, numero3:inteiro
R, S, D:real inico escreva(“ informe n1”) leia(numero1) escreva(“informe n2”) leia (numero2) escreva( “informe n3”) leia (numero3)
R (numero1 + numero2)^2
S(numero2 + numero 3)^2
DR+S/2
Escreva(“ resultado é “, D)
Fimalgoritmo

12. Faça um algoritmo que leia a idade de uma pessoa expressa em anos, meses e dias e mostre-a expressa apenas em dias.

Algoritmo “idade”
var

Relacionados

  • Algoritmo
    1898 palavras | 8 páginas
  • Algoritmo
    774 palavras | 4 páginas
  • algoritmo
    1416 palavras | 6 páginas
  • Algoritmo
    648 palavras | 3 páginas
  • algoritmo
    4368 palavras | 18 páginas
  • Algoritmo
    309 palavras | 2 páginas
  • Algoritmo
    2353 palavras | 10 páginas
  • Algoritmos
    1054 palavras | 5 páginas
  • Algoritmos
    825 palavras | 4 páginas