Algoritmo Resolvidos

2256 palavras 9 páginas
EXERCÍCIOS RESOLVIDOS SALA – LISTA DE ESTRUTURA CONDICIONAL
1) Construa um algoritmo que leia três notas de um aluno, calcule a média obtida por este aluno e no final escreva o resultado indicando se o mesmo foi aprovado ou reprovado
(considere que aluno aprovado obteve Média >= 7,0 e aluno reprovado Média < 7,0). algoritmo "media" var n1,n2,n3,md:real

inicio escreval("Informe tres notas:") leia(n1,n2,n3) md <- (n1 + n2 + n3)/3 se (md >= 7.0) entao escreval("Media do aluno = ",md) escreval("Aluno aprovado") senao escreval("Media do aluno = ",md) escreval("Aluno reprovado") fimse fimalgoritmo
2) Construa um algoritmo que dado as três notas de avaliação de um aluno (AVI, AVII e
AVIII) calcule a média deste aluno. De acordo com a média obtida escreva o tipo de
Conceito que ele obteve. (Para média maior ou igual a 7,0 e menor ou igual a 10, 0 –
Conceito A; para média maior ou igual a 5,0 e menor que 7,0 – Conceito B; para média inferior a 5,0 – Conceito C). algoritmo "media_conceito" var n1,n2,n3,md:real

inicio escreval("Informe tres notas") leia(n1,n2,n3) md <- (n1 + n2 + n3)/3 escreval("Media do aluno = ",md) se ((md >= 7) e (md <= 10)) entao escreval("Conceito A") senao se ((md >= 5) e (md < 7)) entao escreval("Conceito B") senao se (md < 5) entao

escreval("Conceito C") senao escreval("Media inválida") fimse fimse fimse fimalgoritmo
3) Construa um algoritmo que leia sexo, salário e idade de um funcionário de uma certa empresa. Aplique um aumento de 20% sobre o salário

Relacionados

  • Trabalho de algoritmo resolvido
    1037 palavras | 5 páginas
  • Algoritmo
    774 palavras | 4 páginas
  • Exercicios algoritmo
    10739 palavras | 43 páginas
  • algoritmo
    1416 palavras | 6 páginas
  • algoritmo
    4368 palavras | 18 páginas
  • Algoritmo
    1898 palavras | 8 páginas
  • Algoritmo
    1467 palavras | 6 páginas
  • Algoritmo
    309 palavras | 2 páginas
  • Algoritmo
    648 palavras | 3 páginas