Lista de exercícios algorítimo

1302 palavras 6 páginas
HUGO LEONARDO ALMEIDA VIEIRA

RESOLUÇÃO DA ATIVIDADE DE APRENDIZAGEM
PROF. CHARLES MIRANDA FRÓES

HUGO LEONARDO ALMEIDA VIEIRA
1 SEMESTRE – ENGENHARIA DE PRODUÇÃO NOTURNO 2012.2
1ª) Faça um algoritmo que efetue o cálculo de reajuste de salário de um funcionário. Considere que o funcionário deverá receber um reajuste de 15% caso seu salário seja menor que R$ 500,00, se o salário for maior ou igual a R$ 500,00 e menor que R$ 1000,00, seu reajuste será de 10%, caso seja maior ou igual a R$ 1000,00, o reajuste deverá ser de 5%. Imprima o novo salário.
SOLUÇÃO:
algoritmo "reajuste salario"
// Função : reajustar salario
// Autor : Hugo Leonardo
// Data : 10/09/2012
// Seção de Declarações var SALARIO: REAL inicio // Seção de Comandos Escreval("Digite o salário:") LEIA(SALARIO) SE (SALARIO<500) ENTAO SALARIO <- SALARIO*1.15 ESCREVAL(" O salário reajustado é:",SALARIO) SENAO SE ((SALARIO>=500) E (SALARIO<1000))ENTAO SALARIO <- SALARIO*1.10 ESCREVAL(" O salário reajustado é:",SALARIO) SENAO SE (SALARIO>=1000) ENTAO SALARIO <- SALARIO*1.05 ESCREVAL(" O salário reajustado é:",SALARIO) FIMSE FIMSE FIMSE
Fimalgoritmo

2ª) Tendo como dado de entrada a altura e o sexo de uma pessoa, construa um algoritmo que calcule e imprima seu peso ideal, utilizando as seguintes fórmulas:
• HOMEM → (72.7 * ALTURA) – 58
• MULHER → (62.1 * ALTURA) – 44.7

SOLUÇÃO:

algoritmo "PESO

Relacionados

  • Lista de exercicios
    322 palavras | 2 páginas
  • Lista de Exercícios
    1401 palavras | 6 páginas
  • Lista de exercicios
    2265 palavras | 10 páginas
  • Lista de exercícios - matemática
    5073 palavras | 21 páginas
  • Lista de Exercício - JAVA
    1141 palavras | 5 páginas
  • 2 Lista De Exercício
    895 palavras | 4 páginas
  • Lista de exercicios fisica
    978 palavras | 4 páginas
  • Lista de exercícios biioquimica
    1020 palavras | 5 páginas
  • Lista de exercícios Hidráulica
    1142 palavras | 5 páginas