Logica de programacao

1081 palavras 5 páginas
Lista 1 – Lógica de programação 2012-1
Prof. Eimard Gomes

Dado o algoritmo a seguir, responde:
Inicio
Lógico: A, B, C;

Se A = verdade, B = verdade, C = falsidade, quais comandos serão executados?
C1, C6 – Se A é verdadeiro não há necessidade de executar os outros B e C. Se A = Falsidade, B verdade, C = falsidade, quais comandos serão executados?
C3, C4, C5 e C6. Se A = Falsidade, B verdade, C = verdade, quais comandos serão executados?
C2, C5 e C6. Quais São os valores de A, B, C para que somente os comandos C5 e C6 sejam executados?
A e B são falsos. Quais São os valores de A, B, C para que somente os comandos C6 sejam executados?
Para isso A deve ser falso.

2 – Escreva um algoritmo que leia três valores inteiros e diferentes e mostre-os em ordem decrescente. Utilize para tal uma seleção encadeada. var a,b,c : real inicio escreva("DIGITE O PRIMEIRO VALOR: ") leia(a) escreva("DIGITE O SEGUNDO VALOR: ") leia(B) escreva("DIGITE O TERCEIRO VALOR: ") leia(C) Se (a > b) e (b > c) entao ESCREVAL(" A ORDEM DECRESCENTE É : ",a,b,c) senao FIMSE Se (a > c) e (c> b) entao ESCREVAL(" A ORDEM DECRESCENTE É :",a,c,b) senao FIMSE Se (b > a) e (a> c) entao ESCREVAL(" A ORDEM DECRESCENTE É :",b,a,c) senao FIMSE Se (b > c) e (c> a) entao ESCREVAL(" A ORDEM DECRESCENTE É :",b,c,a) senao FIMSE Se (c > b) e (b > a) entao ESCREVAL(" A ORDEM DECRESCENTE É :",c,b,a) Senão FIMSE Se (c > a) e (a> b) entao

Relacionados

  • logica de programação
    681 palavras | 3 páginas
  • Ad logica de programação ii
    1330 palavras | 6 páginas
  • Exercícios de lógica de programação (visual g)
    1234 palavras | 5 páginas
  • Lógica de programação
    2327 palavras | 10 páginas
  • Logica de programação
    1569 palavras | 7 páginas
  • exercicios atps logica de programação
    1415 palavras | 6 páginas
  • Atividade Estruturada Logica de Programação
    494 palavras | 2 páginas
  • Atividade 05 Lógica de Programação
    1843 palavras | 8 páginas
  • APOL 3 LOGICA DE PROGRAMACAO NOTA 100
    1415 palavras | 6 páginas