atividades liguagem programação

16231 palavras 65 páginas
Exercício 1:

Considere que o número de uma placa de veículo é composto por quatro algarismos. foram apresentados três propostas de algoritmos em PORTUGOL que leia este número e apresente o algarismo correspondente à casa das dezenas. Transcreva na justificativa da resposta, a linha exata onde acontece o erro, se houver. (Considere mod = % e div = \)

Proposta A......

algoritmo "Placacarro"

// Seção de Declarações

Var

a,d :inteiro

inicio

// Seção de Comandos

escreva("Entre com o numero de 4 dígitos")

leia(a)

d<-a % 100 \ 10

escreva("O algarismo das dezenas é ",d)

fimalgoritmo

Proposta B

algoritmo "Placacarro"

// Seção de Declarações

Var

a,d :inteiro

inicio

// Seção de Comandos

escreva("Entre com o numero de 4 dígitos")

leia(a)

d<-a % 1000 \ 100

escreva("O algarismo das dezenas é ",d)

fimalgoritmo

Proposta C

algoritmo "Placacarro"

// Seção de Declarações

Var

a,d :inteiro

inicio

// Seção de Comandos

escreva("Entre com o numero de 4 dígitos")

leia(a)

d<-a \ 1000

escreva("O algarismo dos dezenas é ",d)

fimalgoritmo

A - Apenas a proposta A está correta
B - Apenas a proposta B está correta
C - Apenas a proposta C está correta
D - Mais de uma proposta está correta
E - Nenhuma das prospostas está correta
O aluno respondeu e acertou. Alternativa(A)

Comentários:

A - A parte da primeira proposta é a única que esta correta e que dará o resultado das dezenas.
Exercício 2:

Dado o

Relacionados

  • Desenvolvimento de uma ferramenta para comunicação em rede
    4365 palavras | 18 páginas
  • IMPORTÂNCIA DE EXCEL AVANÇADO E VBA PARA O ENGENHEIRO DE PRODUÇÃO E UMA FORMA ALTERNATIVA DE APRENDIZAGEM
    9483 palavras | 38 páginas
  • ADT 1000
    10087 palavras | 41 páginas
  • Resumo aulas - direito constitucional 2
    9322 palavras | 38 páginas
  • gerenciamento com glpi e itil
    11232 palavras | 45 páginas