Ejercicios De Programacion Basica

2676 palabras 11 páginas
CONDICIONES
1. Leer un número entero y determinar si es un número terminado en 4.
Inicio
Entero num
Leer num
res= num%10
si res=4
Escribir "es un número terminado en 4"
sino
Escribir "no termina en 4"
Finsi
Fin

2. Leer un número entero y determinar si tiene 3 dígitos.

Inicio
Entero num
leer num
Si num > = 99 y num < = 1000
Escriba "El número tiene tres dígitos"
Sino
Escriba "El número tiene más o menos de tres dígitos"
Finsi
Fin

3. Leer un número entero y determinar si es negativo.

Inicio
Entero num
Leer num
Si num<0
Escriba “Numero es negativo”
Sino
Escriba “Numero NO es negativo”
Finsi
Fin

4. Leer un número entero de dos dígitos y determinar a cuánto es igual la suma de sus dígitos.
…ver más…
Inicio
Entero Num1, num2, dig1a, dig1b, dig2a, dig2b
Leer num1
Leer num2
Si num1==0 o num2==0
Escribir “Numero invalido”
Sino
Si num1<0
num1=num1*(-1)
Si num2<0
Num2=num2*(-1)
dig1a= num1/10
dig1b=num1%10
dig2a= num2/10
dig2b=num2%10
Si dig1a==dig2a o dig1a== dig2b o dig1b== dig2a o dig1b== dig2b
Escribir “Si, los numeros tienen digitos comunes”
Sino
Escriba “Los números no tienen dígitos en común”
FinSi
Fin

13. Leer dos números enteros de dos dígitos y determinar si la suma de los dos números origina
un número par.

Inicio
Entero num1, num2, suma
Leer num1
Leer num 2
Si num1==0 o num2==0
Escribir “Numero invalido.
Si num1<0
num1=num1*(-1)
Si num2<0
Num2=num2*(-1)
Suma=num1+num2
Si suma/2*2==suma
Escribir “La suma de ambos números origina un numero par”
Sino
Escribir “La suma de ambos numeros No origina un numero par”
Fin si
Fin

14. Leer dos números enteros de dos dígitos y determinar a cuánto es igual la suma de todos los
dígitos.

Inicio
Entero num1, num2, dig1a, dig1b, dig2a, dig2b, suma
Leer num1
Leer num2
Si num1==0 o num2==0
Escriba “Numero invalido”.
Sino
Si num1>9 y num1<100
Si num2>9 y num2<100
Si num1<0
num1=num1*(-1)
Si num2<0
Num2=num2*(-1)
dig1a= num1/10
dig1b=num1%10
dig2a= num2/10
dig2b=num2%10
suma= dig1a+dig1b+dig2a+dig2b
Escriba “La el resultado de todos los digitos de los dos numeros es igual a…

Documentos relacionados

  • Ejercicios de Programacion
    2246 palabras | 9 páginas
  • Ejercicios De Programacion
    1767 palabras | 8 páginas
  • Preguntas Basicas De Programacion
    622 palabras | 3 páginas
  • EJERCICIOS RESUELTOS DE PROGRAMACIÓN LINEAL
    11143 palabras | 45 páginas
  • guia de programacion basica conalep
    18663 palabras | 75 páginas
  • Ejercicio De Programacion Lineal
    786 palabras | 4 páginas
  • Ejercicios programación lineal
    1231 palabras | 5 páginas
  • Ejercicio De Programacion Lineal
    694 palabras | 3 páginas
  • Ejercicios De Programacion En C Deitel
    2311 palabras | 10 páginas
  • Ejercicios Basicos En Netbeans Desarrolados
    1098 palabras | 5 páginas